Рейтинг темы:
  • 0 Голос(ов) - 0 в среднем
  • 1
  • 2
  • 3
  • 4
  • 5
Включение search engine friendly URLs
#1
Включение search engine friendly URLs

Долго очень пытался включить данную опцию на своем форуме, но постоянно после переименования файла .htaccess, и включения опции в админ панели, получал Error 500 Internal Server Error

На официальном сообществе нашел такую ветку

Из файла .htaccess удалил следующий фрагмент:

Код:
Options -MultiViews +FollowSymlinks -Indexes

#
# If mod_security is enabled, attempt to disable it.
# - Note, this will work on the majority of hosts but on
#   MediaTemple, it is known to cause random Internal Server
#   errors. For MediaTemple, please remove the block below
#
<IfModule mod_security.c>
   # Turn off mod_security filtering.
   SecFilterEngine Off

   # The below probably isn't needed, but better safe than sorry.
   SecFilterScanPOST Off
</IfModule>

После чего всё отлично заработало. Если есть другие варианты решений, пожалуйста поделитесь.
Ну и если что-то я делал не так, пожалуйста поправьте.
Ответ
#2
в данном случае вы ничего не потеряли, т.к. фильтр всё равно был отключен. Но, mod_security (http://www.modsecurity.org/) обнаруживает и предотвращает все атаки проводимые и с использованием GET, и с использованием POST запросов. Это всё-таки серверная защита.
(03-23-2016, 01:03 PM)poxmel Написал: Если есть другие варианты решений...
кирилицы в uri присутствует?
выключить все основные директивы модуля, включать по одной и смотреть где отвалится
или, имхо, сменить хостера ))
Ответ
#3
(07-20-2016, 10:55 PM)XTRO Написал: в данном случае вы ничего не потеряли, т.к. фильтр всё равно был отключен. Но, mod_security (http://www.modsecurity.org/) обнаруживает и предотвращает все атаки проводимые  и с использованием GET, и с использованием POST запросов. Это всё-таки серверная защита.
(03-23-2016, 01:03 PM)poxmel Написал: Если есть другие варианты решений...
кирилицы в uri присутствует?
выключить все основные директивы модуля, включать по одной и смотреть где отвалится
или, имхо, сменить хостера ))

Кирилицы нет. Менять хостера не хочется ) Три года и слава богу все работало, а если что-то не так, поддержка помогала. Пока всё так работает. Спасибо за помощь!  Wink
Ответ
#4
У меня в MyBB 1.8.8 также search engine friendly URLs заработали, но не полностью.  В URL не отображается название темы, а просто /thread-5.html Хотя всё сделал по инструкции, то есть переименовал .htaccess и выставил  админке Enable search engine friendly URLs? на Enabled.
Это так и задумано? Для того же Xenforo из коробки всё работает (правда кривовато). Функционал можно расширить с помощью дополнительных плагинов? Каких?
Ответ
#5
(12-07-2016, 01:22 AM)slonik Написал: У меня в MyBB 1.8.8 также search engine friendly URLs заработали, но не полностью.  В URL не отображается название темы, а просто /thread-5.html Хотя всё сделал по инструкции, то есть переименовал .htaccess и выставил  админке Enable search engine friendly URLs? на Enabled.
Это так и задумано? 

У меня тоже так, и если честно, я немного расстроился. Ожидал что в адресной строке будет название темы
Ответ


Перейти к форуму:


Пользователи, просматривающие эту тему: 1 Гость(ей)